Celestron mounts

Discuss Celestron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • AVX not slewing in right direction
    by jazzin United States of America »
    3 Replies
    2688 Views
    Last post by jazzin United States of America
  • Skipping Alignment?
    by 1cor29 »
    21 Replies
    8966 Views
    Last post by Graeme1858 Great Britain
  • WiFi capabilities of Meade LX85 ACF
    by boese1978@q.com United States of America »
    1 Replies
    804 Views
    Last post by Bigzmey United States of America
  • Celestron Heavy Duty Manual Alt Az with tripod
    by helicon United States of America »
    3 Replies
    924 Views
    Last post by helicon United States of America
  • New Accessory Tray
    by SparWeb Canada »
    2 Replies
    713 Views
    Last post by helicon United States of America
  • I potentially fixed my mount.
    by Jnicholes United States of America »
    16 Replies
    1821 Views
    Last post by Graeme1858 Great Britain
  • I need creat a new Accessory Tray
    by Ward Brazil »
    9 Replies
    1030 Views
    Last post by SparWeb Canada
  • Re-Greasing my CGX Worm Drives
    by Graeme1858 Great Britain »
    26 Replies
    3198 Views
    Last post by JayTee United States of America
  • Hand controller.
    by Tillibobs Great Britain »
    8 Replies
    1056 Views
    Last post by Tillibobs Great Britain
  • Yet another mount issue.
    by Jnicholes United States of America »
    27 Replies
    3724 Views
    Last post by Jnicholes United States of America
  • Astromaster 114
    by Lord conDioin Canada »
    3 Replies
    1328 Views
    Last post by JayTee United States of America
  • Tasco And Celestron -- Will It Work?
    by JayTee United States of America »
    2 Replies
    1257 Views
    Last post by JayTee United States of America
  • Am I A Sucker?
    by JayTee United States of America »
    18 Replies
    3439 Views
    Last post by Ylem United States of America
  • SE6 Mount
    by Greenman Great Britain »
    2 Replies
    1190 Views
    Last post by JayTee United States of America
  • Is PEC necessary with ASIAIR?
    by psy1280 »
    1 Replies
    1344 Views
    Last post by Gordon United States of America
  • CGX RA spike/PHD2 Log viewer
    by KC_Astro_Mutt »
    4 Replies
    1965 Views
    Last post by AstroBee United States of America
  • AVX Lights up but doesn't boot or respond
    by StarLord101 »
    24 Replies
    10353 Views
    Last post by turboscrew
  • Does Avx mount beep normally on power on?
    by StarLord101 »
    4 Replies
    1733 Views
    Last post by goldstar
  • CGX-L keeps hitting switch limits!?
    by UlteriorModem »
    21 Replies
    5210 Views
    Last post by UlteriorModem
  • Celesron CGX / CGX-L Celestron or Synta?
    by UlteriorModem »
    1 Replies
    1520 Views
    Last post by JayTee United States of America
  • Another bizarre mount issue.
    by Jnicholes United States of America »
    4 Replies
    2053 Views
    Last post by AstroBee United States of America
  • Another SE mount question: set goto?
    by gregl »
    7 Replies
    7345 Views
    Last post by Lady Fraktor Slovakia
  • CGX mount in the cold
    by I Am Marsha United States of America »
    11 Replies
    9472 Views
    Last post by speedster
  • Mount issue
    by Jnicholes United States of America »
    23 Replies
    26050 Views
    Last post by Jnicholes United States of America
  • iOptron iPolar
    by 1cor29 »
    0 Replies
    2954 Views
    Last post by 1cor29
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum